Windows 10 Creators Update breaks Print Studio


Windows 10 Creators Update breaks Print Studio

Hey folks,

I’ve just confirmed that the latest release of Windows 10, the Creators Update, prevents Print Studio from starting. Unfortunately, since Print Studio is no longer being developed, you will not be able to use Print Studio once you install the Creators Update. You have a few options:

Option 1: Uninstall the Creators Update

  1. Go to Start > Settings
  2. Click on ‘Update & security’.
  3. Select Recovery from the sidebar
  4. Under ‘Go back to the previous version of Windows 10’, click Get Started
  5. Answer the questions and don’t bother installing any new updates (unless you’re reading this post months later)
  6. Once the rollback is complete, Print Studio should work again

Note: make sure you have the “WannaCry” prevention update from March installed:

  1. Open the Start menu.
  2. Type Control Panel then press Enter.
  3. Set the view to Large icons or Small icons.
  4. Choose Programs and Features.
  5. On the left panel, click on View installed updates.
  6. Look for the March 2017 update. You can type KB4013429 in the search bar to find it more easily.

Option 2: Keep the Creators Update and use different software

Netfabb is being actively developed, and I made a video to help Print Studio users get started.

There’s also the slicer, and several other softwares available around the interwebs as well.

Option 3: Use a Windows version other than Windows 10, or use a Mac

Pretty self-explanatory.

Sorry for the inconvenience of this. The Creators Update broke a lot of other software as well.



Ember is the gift that keeps on giving !


Hi Owen,

Any chance you could let us know what error it throws?

Might just be a dependency that was overwritten by the update but which most of us could move before updating Windows.

I don’t fancy any of those 3 options…

Without updating to see what the error is on my machine, it’s hard to guess what it might be… but maybe its something minor that won’t require turning off windows update and missing the next big patch.

Have you had it fail yourself or is this just through support feedback you’ve learned it?

If you’ve learned from personal experience, could you throw up a screenshot just to give us an idea? And had you tried reintalling the software?

Just asking on the off chance something can be done… as I really don’t want to migrate to Netfabb as its way less intuitive.


I believe I was the 1st to report it, the error msgs are here:


I tested and had it fail on my Windows 10 test system. The issue is that the Print Manager service won’t start. Poking around, it looks like there’s some kind of issue with access privileges, but I wasn’t able to figure out what it was.


Installed NetFab today to get used to it before I lose access to PrintStudio.

Crashes on startup, and when I do manage to get it working it keeps giving errors.

Totally un-installed and tried again… this time it didn’t install the visual studio components it did the first time… which I’m guessing means it didn’t remove them when I un-installed it… either way, it didn’t make any difference.

So… to the errors…

On startup, I just get a splash screen, that doesn’t go away.
If I find it in taskmanager (ClicSpashScreenForm), and kill it, I get a startup warning Licence not found dialog, and 'CBW solver not ready!" error, and a button that lets me start a non-licensed version. (clicking the ‘always do this’ cehck box doesn’t seem to have any impact as it shows it every time anyway).

I then get the NetFab app started, but get an error dialog that says ‘could not load file MPAWrapper.dll(126)’ which I have to ignore if I want to keep going.

As soon as I load an STL I get the same error.

If I try to create supports, I get an access violation.

When I google the problem, I get the Autodesk support pages, where friendly support staff explain that if you don’t have a licenced version, you’re not entitled to support.

So… in a nut shell, windows update is going to kill PrintStudio, and the alternative is not working on my machine…

Bit of a nightmare really.


So I have a feeling this might be why I can’t use it…
The above is from the NetFab setup logs…
The install tries to install extra Visual Studio resources during install, if you don’t have them already…

In my case they seem not to have installed correctly… caused a failure, which gets ignored… maybe with good reason, but given that I’ve got DLL not found errors, seems likely to be the reason.

No idea how to get it to completely remove everything and re-install, as when I just uninstalled it last time, it didn’t seem to bother with these…

Any ideas @OwenSmithyman ?


Yikes, that’s no good. Can you locate those Visual Studio resources in your Apps & Features control panel and uninstall them? And are you running Windows via Bootcamp or Parallels?


So I managed to get somewhere by following the logs and seeing what failed on install…

Strangely, Netfab stores all the redist file in "C:\Autodesk\WI\Autodesk Netfabb Premium 2017.3\3rdParty\x64\VCRedist\
So I was able to find all the redist files there and re-install them all… which got rid of my DLL errors (2015 seemed not to have installed, while the other 4 did).

Now I have no DLL errors, but I get an Access Violation dialog when I try to great support structures.

The support that I found online said this was typically an error found on laptops with no graphics card due to a lack of OpenGL support… but I’ve got a Nvidia GeForce GT 750M, which is running fine, and I’ve just re-installed the drivers to make sure there’s no issue there…


Sorry Owen, should have mentioned I’m using bootcamp, not parallels.

I’ve finally managed to get it working by deleting everything in my temp directory (I assume it’s resulted in some netfab config files being removed, and thus reset).

Now that I know it works, at least I have a backup plan, but while I’m sure its a great app for certain things, and I’ll get used to it, it feels like total overkill for Ember, plus the supports don’t seem as good (not connected, so you either make them super thick, or expect a few to break during printing), and I’ll be sticking to PrintStudio as long as I can (and dearly hoping somebody manages to get it working again!)

If anybody does come up with a workaround for getting PrintStudio back up and running with the creators update, I’ll be all ears!


If you are using bootcamp, then why don’t you just use Mac version of Print Studio. I use it everyday, and it works flawlessly STILL.


Thank you for your in-depth work getting NetFabb working again and sharing it here! I 100% agree that NetFabb is a poor solution for Ember users. The ‘work flow’ is overly complicated and someone who paid $7500 for a printer isn’t going to want to pay $4000 for the software to run it. Unfortunately, I haven’t found any better solution than PrintStudio. I wish MeshMixer could directly print to the Ember.


Thanks @patrickleephoto it’s certainly an option I’ll consider.

I use bootcamp so that I can use Rhino for windows, and really didn’t like the Mac version of Rhino… so printing via the Mac print studio would involve rebooting my machine just to print, or saving STLs to a network drive and printing from a seperate Mac… which while a bit of a faff, is still probably preferable to using NetFab based on my limited experience of it.

Mac software does seem to often require updating with big OSX updates too… so I suspect I wouldn’t be able to use the solution indefinitely anyway if PrintStudio is no longer actively developed, but it’s certainly a good plan B, so thanks for sharing!


Glad you got Netfabb working, and thank you for sharing how you did it! The new design team is starting to ramp up, so my hope is that the interface significantly improves over the next few months. And in the meantime, Print Studio seems pretty solid on Mac.


Hi, I have tried to use today & it does create a zip file with png slices but any idea how I get these to work with Ember? Up until now the software I used produced a .tar file rather than a zip. Many thanks.


I use the web interface. If you are familiar with loading the .tar files through the web interface, then it is the exact same for ZIP files. I’m not sure about loading using a USB, though I suspect it should work too.


Correct, you can treat .tar and .zip files exactly the same way in all circumstances.


The Win 10 update was the best thing to happen to Print Studio for me. It totally broke Studio for me, and forced me to try Cura instead. The crappy trees in Print Studio were to fragile and broke loose 50% of time, but Cura has more reliable tree methods. My print quality has never been better. Cura has a crappy looking interface, but the actually functionality is excellent.


I have only ‘poked around’ in CURA - can you share the workflow us use?
Did you have to set up a custom printer? How difficult was that?
What about getting the file onto the Ember: Is it a ZIP file that is loaded via the web portal?