Warping of prints with small features


#1

I have a question regarding warping/bowing of my prints. I am printing micro lattices, the smallest negative feature is 440 microns, and the smallest positive feature is 300microns. The whole cube is 4mm x 4mm x 4mm and I’m printing in 10 micron layers.

When I print my lattices at 45 degrees, as seen in the photo, everything prints fine, except when I get to the last 1/3 of the structure or so (the top portion of the lattice in the pic below). I get a warping of the struts. I thought it might have to do with the tray rotating and the layers getting misaligned. I tried increasing the wait time before the projector lights up so that the resin can equilibrate and settle but that didn’t do anything.

I am also posting my 5mm and 6mm build. The 5mm came out relatively fine, and the 6mm not so great.

Any ideas what the issue may be?

4mm

5mm

6mm


#2

Hello,

It is an interesting issue. It seems like your object moves a little bit during the printing process, but only on the last 1/3 of the object. Is it possible that some layers are missing? Did you notice any jams at this part of printing? It looks like the tray is not coming back at the same position.
Did you observe the same phenomenon printing larger objects (cm row)?


#3

Have you tried not rotating the tray at all, just lifting the part straight up? With lattice structures, you should be able to do this.

I do think you are on the right track with increasing the wait time. Other parameter to try changing:
Tray rotation speed - reduce both the peel and approach speeds
Z approach speed - reduce the speed the build head approaches the resin


#4

I do not think layers a missing, from what I can see on Print Studio. No jamming is observed either… The 6mm was the biggest I’ve printed, I have no printed anything bigger than that in this orientation. I can try that!


#5

To stop the tray from rotating, I would have to SSH right? Ideally I would want to print with the tray stationary.

I will look into changing those other settings. Thank you!


#6

You actually don’t have to SSH in - you just need to be able to edit the printsettings file in Brackets.

I am including a file that I have used in the past to disable the jam detection and turn off the rotation.

  1. Once you have exported your print in PrintStudio, unzip the tar.gz file.
  2. You can then either:
  • Open both printsettings files in Brackets and Manually copy lines 56 to 58 into your existing printsettings file and change all the rotation settings to 0 (unless you saved a custom profile in PS with these already set to 0)

OR

  • Replace your existing printsettings file with this one. You will need to open the file in Brackets and change the exposure settings values to match your existing settings.

Once you have the file updated, you will need to re-ZIP the file with the image stack and send that over to the printer.

I am also including a ZIP file to ‘reset’ the printer to it’s normal operation once your done. Just send it over after your done using the No Tray Rotation settings. It includes a single blank exposure so nothing will actually print - it just resets the printer so you don’t have to SSH into it.

Let me know if you have any problems with these files. I haven’t used them in a while but believe them to still be OK.

printsettings (2.1 KB)
Printer Reset File.zip (1.3 KB)


#7

Yes, use SSH to stop the tray from rotating. Set DetectJams to 0 and set FirstLayerRotation (BurnInLayerRotation and ModelLayerRotation) to 0 as well. Should work. I agree with @scott_chabineau you should be able to print lattice with no rotation. I did successfully it with bigger surface area lattice.

It is interesting if warp appears in a certain height.


#8

Once I open PuTTY and enter root, what do I input on the next line to set those settings to 0?

Sorry, this is my first time.

Best,
Alina


#9

Thank you! I will try this if I can’t figure out the SSH… I am not sure what to input once I enter the root command.


#10

Please, follow the link: https://support.ember.autodesk.com/hc/en-us/articles/229505168-Changing-Ember-s-settings-via-Terminal-PuTTY


#11

@Edvis

I am putting in the command nano /var/smith/config/settings as it says in the Ember user manual but I get back “-bash: nano/var/smith/config/settings: No such file or directory”


#12

It is even more strange. The command works to me.
It is important to type exactly you did: nano /var/smith/config/settings. I mean, a space between nano and /var is mandatory.
I don’t know, why ember shows it without space.


#13

Yeah, you’re just missing the space between nano and /var. It should work correctly once you add it in.

Thanks everyone for chiming in!


#14

@OwenSmithyman @Edvis @scott_chabineau

For model layer I am only seeing:
“ModelSeparationRPM”: 8,
“ModelApproachRotJerk”: 100000,
** ModelApproachRPM": 8,
“ModelZLiftMicrons”: 750,
“ModelSeparationZJerk”: 99999,
“ModelSeparationMicronsPerSec”: 1000,
“ModelApproachZJerk”: 99999,
“ModelApproachMicronsPerSec”: 1500,
“ModelRotationMilliDegrees”: 60000,
“ModelExposureWaitMS”: 0,
“ModelSeparationWaitMS”: 0,
“ModelApproachWaitMS”: 1500,
“ModelPressMicrons”: 0,
“ModelPressMicronsPerSec”: 1500,
“ModelPressWaitMS”: 0,
“ModelUnPressMicronsPerSec”: 1500,

Are the bold settings the ones I set to 0?


#15

Change
“ModelRotationMilliDegrees”: 0, (prevents rotation)

Do not Change
ModelApproachRotJerk


#16

And once I change all of the MilliDegree settings, how do I print a certain stl file? I am really sorry, I appreciate all of the help.


#17

If you are changing these settings via SSH then do this:

  1. Import STL into PS.
  2. Prepare / Process the part as you normally would.
  3. Send the file to the printer
  4. Once the part is loaded into the printer’s memory - SSH into it
  5. Using the nano /var/smith/config/settings command you will pull up the printer settings
  6. Edit the lines as discussed
  7. Save the setting changes on the printer using ctl+o (the key commands are listed at the bottom of the terminal window)
  8. It will prompt you to confirm the save - press y and enter
  9. Exit the edit prompt using ctl+x
  10. Type: echo refresh > /tmp/CommandPipe
  11. Start your print from the printer console - ‘calibrate…’ etc

See here for more info on SSH


#18

Don’t forget to change ‘Detect Jams’ to 0


#19

I will give that a try! Thank you!


#20

Hey @scott_chabineau! Have you ever tried printing mesh lattices? For example, using Meshmixer to create the lattice and printing that file?

Thank you!