How to stop the tray from rotating


Good morning.
We are testing the machine with a different basis and we would like to exclude the motor of the rotary plan on all its settings, even on the initial ceck.
Thank you

Alternating pixels within a layer

In that case you’d want to change the following settings via SSH:

  • RHomingAngleMilliDegrees = 0
  • RotateHomeOnApproach = 0
  • FirstRotationMilliDegrees = 0
  • BurnInRotationMilliDegrees = 0
  • ModelRotationMilliDegrees = 0
  • RStartPrintPositionMillidegrees = 0
  • DetectJams = 0

Let me know if that works for you. I’d love to see any pictures of your setup, or of the things you print!

Resin Tray Rotation

I am also interested in this.
Owen, where do we input these values? We SSH with Putty?


Oops, yes, I should have mentioned that. See below:

Access to Firmware through PrintSettings file

I am pleasantly surprised !

I was under the impression we will have to modify firmware to make these changes.
It’s awesome that Ember made provisions like that to allow users to go their own way modding their 3D printer.

BTW, these settings will remain in effect after Ember reboot?


Yes, the settings will stay even with a reboot. But note that Rotate Home on Approach can also be set in Print Studio advanced settings, so make sure it’s turned off there or it will override the manual setting you just made.


Can all these values be set in a LayerSettings.CSV file?


No, these are printer settings, not print settings. They can only be changed by altering the /var/smith/config/settings file over SSH.


Could you post a copy or print screen of the original settings? I got a little carried away with customizing for my prints and need to put it back for another user. Thanks!


I have a printer reset file that I send over via the web interface.
Printer Reset (1.3 KB)


sorry…where the heck are the advanced settings in Print Studio?


In PS - in the upper left corner > Click the gear…


then at the bottom of the dialog box, click the down arrow next to Advanced Settings



However - if you are trying to stop the tray from rotating, you won’t be able to complete all the steps needed. The Advanced Settings doesn’t include any option to turn off Jam Detection. :face_with_raised_eyebrow:


Here is a printsettings file that turns off tray rotation.

To use this, first export your print from PS.
Then extract the tar.gz file.
Replace the printsettings file the PS created with this one. You will need to use Brackets or similar to edit the exposure times, rotation speeds, etc…
(Alternately - you can locate the various code changes in this file and just add / change your printsettings file)

No Tray Rotation printsettings (577 Bytes)

And don’t forget to load the reset file when you want to go back to normal operations
Printer Reset (1.3 KB)

Rotate platform after each layer

sorry novice here…I did get to the print file…do you just replace the one with the one you sent or do I have to modify it?
I attached the printprintsettings (2.0 KB)


You would need to modify it based on your needs. I have made a couple of mods to prevent it from rotating on the model layers only. This seems best based on the screen shot.

printsettings (2.1 KB)

Depending on the wall thicknesses, you may need to adjust the exposure times and/or the support attachments. I’m pretty new to the ‘No Rotation’ scene so I’m not 100% sure what will happen.

However, here are the details to the changes I made.

  1. Added lines 55-57 - 56 and 57 can be changed to 0 if you want the tray to not rotate during startup.


  1. Changed line 47 from 60000 to 0 (no rotation)

  2. Changed line 53 from 750 to 1500 (lift the build head 1.5mm vs .75 to ensure separation)