Front panel reset


#1

hey guys,

I just got an issue that after rebooting the Ember, the front panel just got stuck and never shows up the print information. The LED ring still blinks but the screen is completely dark. I pulled out the cable and replugged but nothing change.

Any idea how to reset the front panel ?

Thank you


Ember wont turn on
#2

Hmm, did you change anything such as firmware before rebooting? If not, that’s pretty odd. Are you able to connect via USB (SSH, web interface, etc)? Do you see orange blinking lights on the main control board underneath the projector?


#3

hey Owen,

No, I did not change anything of the firmware. Before I reboot, I was running a print, but the front panel was frozen and the print just stopped. so I restarted. After that, the front panel went like that…

I can ssh in the printer and change file settings. and the orange light on the main board is blinking

thank you


#4

also, is there a way to start/stop the print via terminal? I wanna at least keep printing going…
thanks!


#5

This has happened to me few times. Everytime this happened, I had to re-flash the 3.0 firmware and install the latest one. Then everything worked fine.


#6

thanks patrick,

did you use the web portal to update the firmware or microSD card?

thanks


#7

Sorry. I had to use microSD card to get going. Once you re-flash Firmware 3.0 with microSD, don’t forget to flash it again with latest version of firmware.

Patrick


#8

thanks, which instruction you followed for flashing the 3.0 version of firmware?

I tried [this](https://support.ember.autodesk.com/hc/en-us/articles/209662848-How-to-update-Ember-s-firmware) one but the problem is still there. After I insert the microSD card, and connected power to the printer, the front panel did now show anything, still just LED ring circling ///


#9

Hmmm. That is all I did. Just inserted the microSD card. Ember updated firmware after I plugged it back in. Did you put the Firmware 3.0 sd card all the way in? I am pretty sure you did, but I just had to ask. Maybe you have some other issue with the printer.


#10

I’m wondering if it’s the problem of the panel or the main board.

anyone know how to start/stop print from the terminal?

thanks


#11

That’s rather odd. Maybe reflashing the AVR on the front panel might help? Give that a shot and let me know what happens.

To start a print, use echo start > /tmp/CommandPipe. Replace start with cancel to stop a print. See the full list of terminal commands here (scroll down to command strings).


#12

hey Owen,

I tried refreshing the AVR. the .hex file is flashed on the board (based on the feedback from the terminal.) but the screen turn from black to this:

after rebooting, problem remains… the screen is still black and led still just circling. :frowning:


#13

The static on the screen is normal while updating, but I see that it still doesn’t work. You have an extra main board, correct? Could you try plugging in the screen to that board?


#14

Hey Owen,
I did the test. the screen is still black with the extra main board that I have. Please see the attached photo… Do you think I could purchase an extra board somewhere as a replacement?

Thank you


#15

hey Owen,

the command is to start a print with calibration. what is the commend that confirm the build platform calibration and actually start a print? the STARTPRINTDATALOAD ?

thanks


#16

Looks like it’s broken, so I’ll send you a new front panel. Same address as before?

To confirm calibration, I think you’d have to use the BUTTON2 command to simulate pressing “Done”.


#17

Thanks Owen! yes same address. 75 amherst.

the command button2 did not work. after I sent that, other command including cancel stopped working as well…I guess I’ll just wait for the new front panel board.

Thank you!


#18

I just ran into the exact same problem after upgrading to the latest firmware the autodesk logo is on and the leds are flashing in circles. but nothing is happening. also the when I connect via USB the printer keeps disconneting


#19

Did you upgrade via a MicroSD card, or via the web? Do you know what version of the firmware you were running before you upgraded?


#20

I first tried via the web and it didn’t work so I upgraded via the microsd. and the upgrade went smoothly however when I reboot i get the autodesk logo and flashing circles. as for the previous version