Error 36-29 : Motion Control


#1

This error message keeps popping up in one of my Embers when I start a print job. I tried resetting the print job and turning the printer off and back on. Does anybody here know how to solve it?


#2

A few more details on my issue (that is still persisting):

  • This error pops up in both of the embers in my lab
  • I am able to 3d print other parts with no issues
  • In the past, I was able to print an almost identical part to the one that I am trying to print
  • Since I realized that this issue was happening for this particular part, I changed the resolution of the stl file and tried without supports, none of which solved the problem
  • Before my error message pops up, the “time remaining” message in the screen is somehow blurry with the numbers overlapping each other.

I would definitely appreciate some help! Thanks!!


#3

Did you change anything in the “printsettings” file manually using Brackets (or similar)? I receive error messages (though I don’t recall this specific message) sometimes when I enter an incorrect / unsupported value or leave out a comma.


#4

I actually don’t think that’s the error. I recall that error and it did not let me start printing at all, while with this one the print job lasts like 5 min. Thanks though!


#5

Does it correspond with start of the model layers, or just sometime after?
Does it correspond with a particular layer - in that if fails at that layer everytime - or is it random?
Do you have detect jams turned on or off?
Does it sound any different before it fails or it just stops?
What part of the layer cycle is the build head in - tray rotation, moving in the Z axis, waiting for exposure, etc…?


#6
  • It happens at the very first model layer
  • It does not correspond to a particular layer, as I have obtained same results with and without supports
  • I did select “Use rotation homing for approach” so I think that that would take care of the jamming. Other than that, I have not changed anything regarding jamming issues
  • It does not make any noise, it just stops
  • The build head is in waiting for exposure when it stops

This is the image that shows up before my error pops up:


#7

Hmmmm…
Rotation homing doesn’t turn on jam detection that I’m aware of, it will just force the printer to reset the rotation zero if a jam occurs. I don’t think this is the problem however.

Can you tell if the build head moves down just before it errors out? I’m wondering if there is something off in this printsettings files that either:
a. tells the motor to move too fast or too slow on the Z axis move
b. has the layer thickness set incorrectly for the model layer

If the tray rotates into position and the build head doesn’t move down, there may be something wrong with:
ModelApproachMicronPerSec
ModelApproachWaitMS

If the build head moves down and then it errors out (and your not controlling the layer thickness with a Layersettings file), then the only thing I can think of would be in the ModelApproachWaitMS - unless your trying to overpress…

Not sure if this is helping at all, but hopefully this can help narrow it down.

If you want me to look at the file I can. Maybe I see something, maybe I don’t…


#8

I have fixed it! I re-did the file since that one just seemed corrupted. I changed the slide velocity from 0.25 to 0.5 rpm and that took care of it. I think 0.25 was probabaly too low.

Thank you so much for the help


#9

Excellent! Glad it works now.


#10

Ah, now this makes sense – slide velocity only takes integer values, so anything below 0.5 must have been rounded down to zero, which would lead to an infinite amount of time remaining (hence the overlapping numbers on the screen, which was the biggest number the machine could display). Now that you’re using 0.5, it’s getting rounded up to 1 RPM, which makes it work properly. It’s unfortunate that we chose to make that value an integer, as it would be useful to be able to set it to less than 1 RPM.

Thank you @scott_chabineau for helping with troubleshooting!


#11

Exactly! I noticed in my print file that the rpm velocity was 1 rpm instead of 0.5rpm… had never catched that one. And yeah, thanks a lot @scott_chabineau